Back to overview
Degraded
Degraded dashboard performance
Apr 28 at 04:25pm UTC
Affected services
Dashboard
Resolved
Apr 28 at 04:54pm UTC
This issue appears to be resolved. We will continue monitoring.
Affected services
Created
Apr 28 at 04:25pm UTC
We are currently experiencing prolonged load times for the Messages page on the dashboard. We are investigating the issue and hope to have a fix shortly.
Affected services