Back to overview
Degraded
Message delivery delays
Jun 27 at 03:30pm UTC
Affected services
Send message
Resolved
Jun 27 at 07:45pm UTC
We can confirm that this issue was resolved around 1:10pm ET, and the queues have been cleared. Any impacted messages should now be delivered.
Affected services
Updated
Jun 27 at 05:10pm UTC
The issue appears to be resolved, waiting for confirmation now.
Affected services
Created
Jun 27 at 03:30pm UTC
Outbound SMS/MMS messages are experiencing delivery delays for some customers (stuck in SENT status). This issue appears to be related to network maintenance being conducted by our SMS carrier partner. They are working urgently to fix the issue. We’ll share another update shortly.
Affected services